summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatt Kohls <mattkohls13@gmail.com>2023-10-22 18:39:15 -0400
committerMatt Kohls <mattkohls13@gmail.com>2023-10-22 18:39:15 -0400
commit7690f350671cd22868d04f91d5423b56c14ad107 (patch)
treed29f05722f083a93083feec1a0fc7e45274d1e07 /Cargo.toml
downloadweather-data-aggregator-7690f350671cd22868d04f91d5423b56c14ad107.tar.gz
weather-data-aggregator-7690f350671cd22868d04f91d5423b56c14ad107.tar.bz2
weather-data-aggregator-7690f350671cd22868d04f91d5423b56c14ad107.zip
Initial bits to get weather.gov info
Hits up weather.gov and publishes info to a local mqtt broker, bits work in progress
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..f9b6b43
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "weather-data-aggregator"
+description = ""
+version = "0.1.0"
+edition = "2021"
+authors = ["Matt Kohls"]
+license = "GPL-3.0-or-later"
+publish = false
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+reqwest = { version = "0.11", features = ["json", "blocking"] }
+serde = { version = "1.0", features = ["derive"]}
+serde_json = "1.0"
+paho-mqtt = "0.11"
+config = "0.13.1"